GPG 1.1.92 bogus error for IDEA plugin

Werner Koch wk at
Thu Sep 12 19:10:01 CEST 2002

On Thu, 12 Sep 2002 10:16:29 -0500, Larry Ellis said:

> When I run --version on 1.1.92, IDEA is missing from the cipher list.
> Also, there are a number of missing hash algorithms:  Tiger, and all the SHA
> variants except SHA1are missing, all of which I thought were now statically

If you need TIGER you may use ./configure --enable-tiger.  The use of
this algorithm is not sugested because it is not sufficiently defined.

We don't have any SHA-{256,384.512} implementations yet (i.e. the
paperwork has to be done).  And there is nothing you can do with it
because DSA requires a 160 bit (this requirement is hard coded in
GnuPG) and after all adding more algorithms today will only make the
teh compatibilty problems harder.  Anyone wants to get into the same
problems as with CMS/X.509?



More information about the Gnupg-devel mailing list