Help, I'm confused (how to package cryptplug)

Werner Koch wk at
Mon Apr 19 15:01:44 CEST 2004

On Mon, 19 Apr 2004 14:23:08 +0200, Michael Nottebrock said:

> Just to make sure I'm getting this right: gnupg 1.9.x (== the backend?) can be 
> built with both gpgme-0.3.16 (which I would need to do, since it's the gpgme 

Better to say: Applications linked against gpgme-0.3.16 may be *used*
with GnuPG >= 1.9.x (as well as with the old newpg).

GnuPG >= 1.9 may be used with any GPGME version >= 0.3.16 (including
of course 0.4.x).

> version available in ports and I want to provide crypto plugins for the kmail 
> in KDE_3_2_BRANCH) and gpgme-0.4.x?

As I always get the Kmail/KDE versions wrong, Marc should answer

Just to make it clear what the backend consists of:

  GnuPG 1.9
    including the programs gpgsm, gpg2 gpg-agent, scdaemon and gpgconf
    (gpg2 is basically an older version of gpg 1.3.x and it is in
     general better to use the regular gpg (gnupg 1.2.x or gnupg
     1.3.x) - thus we changed the name to gpg2)


    Well, actually it is a kind of hermaphrodite as it is used
    by the backend but actually be a part of the frontend (visible by
    the user)

GPGME is part of the backend from the view of the developers but not
from a user's POV because it is linked to Kmail and other KDE apps.



More information about the Gpa-dev mailing list