Help, I'm confused (how to package cryptplug)

Marc Mutz mutz at
Fri Apr 23 09:32:06 CEST 2004

On Monday 19 April 2004 14:23, Michael Nottebrock wrote:
> Just to make sure I'm getting this right: gnupg 1.9.x (== the
> backend?) can be built with both gpgme-0.3.16 (which I would need to
> do, since it's the gpgme version available in ports and I want to
> provide crypto plugins for the kmail in KDE_3_2_BRANCH) and
> gpgme-0.4.x?

KDE_3_{1,2}_BRANCH only works with CryptPlugs, which require gpgme 
Note that due to a bug in KMail, you will need a post-KDE 3.1.5 KMail 
for the new backend to work (3.2.x is fine), ie. from CVS.

We will do a release of HEAD kdepim as "kdepim 3.3 for KDE 3.2" later 
this year, which will include a KMail that doesn't use CryptPlugs 
anymore, and which requires gpgme >= 0.4.5.

Hope this helps,

The DMCA is unconstitutional, but they don't care. Until it's ruled
unconstitutional, they've won. If they can scare software companies,
ISPs, programmers, and T-shirt manufacturers [...] into submission,
they've won for another day. The entertainment industry is fighting a
holding action, and fear, uncertainty, and doubt are their weapons. We
need to win this, and we need to win it quickly. Every day we don't
win is a loss.                 -- Bruce Schneier, Crypto-Gram Aug 2001

More information about the Gpa-dev mailing list