Undefined symbols libgcrypt-1.2.0/tests/ac.c (Solaris 2.7)

Eduardo Espejo Gavilano eduardo.espejo at t-empresas.com.pe
Thu Apr 14 16:42:47 CEST 2005

I have the same problem on solaris 2.6, I think it is about the linker or
libtool. On Solaris with non-gnu linker, libtool generate this command for
the shared library:

gcc -shared -Wl,-h -Wl,libgcrypt.so.11 -o .libs/libgcrypt.so.11.2.0
.libs/libgcrypt_la-misc.o .libs/libgcrypt_la-global.o
.libs/libgcrypt_la-sexp.o .libs/libgcrypt_la-stdmem.o
.libs/libgcrypt_la-secmem.o .libs/libgcrypt_la-missing-string.o
.libs/libgcrypt_la-module.o .libs/libgcrypt_la-ath.o -z allextract
../cipher/.libs/libcipher.a ../mpi/.libs/libmpi.a -z defaultextract
-R/usr/local/lib -R/usr/local/lib -L/usr/local/lib
/usr/local/lib/libgpg-error.so -lnsl -lsocket -lc

It seems that the linker can not extract all symbols from libcipher.a
because "allextract" does not  work fine at all,  I solved the problem with
the gnu linker, just rename the path of the non-gnu linker so gcc or cc
will take the gnu-linker commonly installed in /usr/local/bin. With gnu
linker the command looks like this :

gcc -shared  .libs/libgcrypt_la-misc.o .libs/libgcrypt_la-global.o
.libs/libgcrypt_la-sexp.o .libs/libgcrypt_la-stdmem.o
.libs/libgcrypt_la-secmem.o .libs/libgcrypt_la-missing-string.o
.libs/libgcrypt_la-module.o .libs/libgcrypt_la-ath.o -Wl,--whole-archive
../cipher/.libs/libcipher.a ../mpi/.libs/libmpi.a -Wl,--no-whole-archive
-Wl,--rpath -Wl,/usr/local/lib -Wl,--rpath -Wl,/usr/local/lib
-L/usr/local/lib /usr/local/lib/libgpg-error.so -lnsl
-Wl,--version-script=./libgcrypt.vers -Wl,-soname -Wl,libgcrypt.so.11 -o

--whole-archive instead allextract

Hope this help

Eduardo Espejo

             Henry Jen                                                     
             <slowhog at jxta.org                                             
             >                                                        Para 
             Enviado por:              gcrypt-devel at gnupg.org              
             gcrypt-devel-boun                                          cc 
             ces at gnupg.org                                                 
                                       Re: Undefined symbols               
             13/04/2005 21:15          libgcrypt-1.2.0/tests/ac.c (Solaris 

 <lanz <at> wsl.ch> writes:

> On 10 Dec 2004, stamer <at> flower.theory.informatik.uni-kassel.de wrote:
> >
> > Hello libgrypt-team,
> >
> > the following error appears during the build of libgcrypt-1.2.0 on
> > Solaris (with non-gnu linker). It seems to me, that the listed
> > symbols are not in libgcrypt.so but they appear in
> > libgcrypt.a. --disable-ld-version-script does not help. The created
> > config.log is attached.
> >
> > .... (dropped)
> I can confirm the build error under Sun Sparc Solaris 2.9 (non-gnu
> linker). I still get a very similar error with the new libgcrypt
> version 1.2.1 (see below).

I have same problem with 1.2.1 on Solaris 10(non-gnu linker). Have you
out  this? If so, would you please let me know how to solve this?

Many thanks,

Gcrypt-devel mailing list
Gcrypt-devel at gnupg.org


More information about the Gcrypt-devel mailing list