[PATCH] Curve25519 patch revised
wk at gnupg.org
Fri Jun 20 11:08:16 CEST 2014
On Fri, 20 Jun 2014 04:23, gniibe at fsij.org said:
> mpi_swap_conditional is used in _gcry_mpi_ec_mul_point for Montgomery
> curve (model == MPI_EC_MONTGOMERY).
Can you change the name to mpi_swap_cond ? I would also prefer to keep
it an internal function for now and add it to the public API only
later. This allows to backport it to 1.6.
> To do so, we need to add two more fields in the curve specification:
> co-factor and number of bits of the curve (to set MSB of above code).
Die Gedanken sind frei. Ausnahmen regelt ein Bundesgesetz.
More information about the Gcrypt-devel