Decrypt using BcryptDecrypt

Mandar Apte mandar.apte409 at
Tue Jun 2 13:27:23 CEST 2020

Hello team,

           I am trying out Libgcrypt 1.85 APIs for AES 256 encryption in
CBC mode on Fedora computer. I have a windows 10 computer on which I have
installed oracle virtual box and running a Fedora OS machine in it.

Firstly, I tried encryption and decryption on Fedora using Libgcrypt APIs.
It worked so easy and Smooth with no error and data loss.

Since nowadays cross platform capability has become a MUST point in
software world, I am also trying to test encryption and encryption in cross
platform scenario.

 I am trying to encrypt file on fedora using Libgcrypt APIs, and decrypt
that encrypted file on windows.

On windows I am using Bcrypt library which also supports AES 256 in CBC

The problem I am facing right now is, I am getting an error from
BcryptDecrypt() function on windows when I try to decrypt the file
encrypted on Fedora box.

Though the surprising thing is when I pass the entire encrypted file
content all at once to BcryptDecrypt() it is able to decrypt the data
correctly with no data loss, but it still returns error code "-1073741762
(0xC000003E) which means as" STATUS_DATA_ERROR" in windows.

Hence, I wanted to check, if the Libgcrypt APIs are doing padding
internally since I am not passing any such instruction to the Libgcrypt
library explicitly?

I am kind of stuck in this since 2 weeks now. I tried all possible things,
checked endianess, byte size etc on both Fedora and windows computer.

I need some help here to know internal behaviour if Libgcrypt library.

Please help me.

Thank you in advance.

Best Regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Gcrypt-devel mailing list