gpg-agent 'crashes' with libgcrypt 1.9.0

Vladimir Lomov lomov.vl at
Sat Jan 23 03:32:27 CET 2021

** Werner Koch <wk at> [2021-01-22 17:53:17 +0100]:

> On Fri, 22 Jan 2021 11:38, Vladimir Lomov said:

>> Jan 21 10:13:33 gpg-agent[25312]: free(): invalid pointer


> has a fix.  I am going to release 1.9.1 next week.

I built libgcrypt 1.9.0 with this patch (took it from and
tried to run

$ gpg -s --clearsign -b PKGBUILD

but it ended with the same error for both distribution package and locally
rebuilt one.

Is there a way to debug this? I experimented with running gpg-agent under gdb
and strace but, obviously due to security reasons, couldn't get it to work.

> Shalom-Salam,

>    Werner

WBR, Vladimir Lomov

Nuclear powered vacuuum cleaners will probably be a reality within 10 years.
		-- Alex Lewyt (President of the Lewyt Corporation,
		   manufacturers of vacuum cleaners), quoted in The New York
		   Times, June 10, 1955.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 228 bytes
Desc: not available
URL: <>

More information about the Gcrypt-devel mailing list