Exposing the gcry_md_hash_buffers_extract function

Werner Koch wk at gnupg.org
Fri Mar 8 10:24:02 CET 2024

On Fri,  8 Mar 2024 15:28, NIIBE Yutaka said:

> While we have gcry_md_hash_buffers in libgcrypt, and
> _gcry_md_hash_buffers_extract internally, we don't have the
> gcry_md_hash_buffers_extract function exposed.

I think we should use a better name for that function.

gcry_md_hash_buffers_extract is the same as gcry_md_hash_buffers with
the addition of the size of the provided result buffer.  Thus
gcry_md_hash_buffers_ext sounds like a better name to me

> Shall I do that for next libgcrypt release?




The pioneers of a warless world are the youth that
refuse military service.             - A. Einstein
-------------- next part --------------
A non-text attachment was scrubbed...
Name: openpgp-digital-signature.asc
Type: application/pgp-signature
Size: 247 bytes
Desc: not available
URL: <https://lists.gnupg.org/pipermail/gcrypt-devel/attachments/20240308/d98a61d0/attachment.sig>

More information about the Gcrypt-devel mailing list