[PATCH] cipher:ecc: Add curve ietf25 with exact RFC8410 semantics.

Werner Koch wk at gnupg.org
Thu Aug 6 16:12:20 CEST 2026


Hi!

Thanks for the patch.  My wk/rfc9980 branch does now work properly when
using this patch.  I did a minor modification:

-    { "ietf25" },                            /* rfc9580 */
+    { "ietf25",     "1.3.6.1.4.1.11591.15.25" },/* rfc9580 */

which should make

> (find_domain_parms_idx): Allow curve with no other name.

superflous, but it doesn't harm to have it anyway.
I added the new OID, so that we have a uniform system.  RFC9580 does not
use OIDs for the new algos but I think it is better to have it.   from
doc/DETAILS which reflects the parts of the GNU arc:

  1.3.6.1.4.1.11591.15           EllipticCurves
  1.3.6.1.4.1.11591.15.1           Ed25519
  1.3.6.1.4.1.11591.15.25          ietf25

  The curve ietf25 is actually X25519 as specified by RFC-7748.  We used
  the name X25519 already as an alias for Curve25519 in Libgcrypt but
  with slighly different semantics.

Iam going to update gnupg.org/oids.html also.  The GNU site is currently
not reachable but we should tell them the new entry also.


Shalom-Salam,

   Werner

-- 
The pioneers of a warless world are the youth that
refuse military service.             - A. Einstein
-------------- next part --------------
A non-text attachment was scrubbed...
Name: openpgp-digital-signature.asc
Type: application/pgp-signature
Size: 284 bytes
Desc: not available
URL: <https://lists.gnupg.org/pipermail/gcrypt-devel/attachments/20260806/72fc4723/attachment-0003.sig>


More information about the Gcrypt-devel mailing list