[git] GnuPG - branch, STABLE-BRANCH-1-4, updated. gnupg-1.4.12-11-g6a41f38

by Thomas Klausner cvs at cvs.gnupg.org
Tue Nov 6 19:52:10 CET 2012


This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "The GNU Privacy Guard".

The branch, STABLE-BRANCH-1-4 has been updated
       via  6a41f385c496c180ee730ce80ff5653746410759 (commit)
       via  620906643713e839b4a95714013ee4603fedc515 (commit)
      from  5093bed27580e608de073bcc5953bd76b6b8b2de (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
commit 6a41f385c496c180ee730ce80ff5653746410759
Author: Thomas Klausner <wiz at NetBSD.org>
Date:   Sat Oct 27 19:56:11 2012 +0200

    Handle systems which have uint64_t but not the UINT64_C macro.
    
    * include/types.h (U64_C) [!UINT64_C]: Add simple replacement.
    
    --
    This could happen with UNIX98-type systems, such as the code on
    the netbsd-1-5 branch, and would prevent this package from building
    on such systems.

diff --git a/include/types.h b/include/types.h
index 7d93865..6baccdb 100644
--- a/include/types.h
+++ b/include/types.h
@@ -101,9 +101,14 @@ typedef unsigned long u32;
 # undef u64	    /* maybe there is a macro with this name */
 # if SIZEOF_UINT64_T == 8
 typedef uint64_t u64;
+# ifdef UINT64_C
 #  define U64_C(c) (UINT64_C(c))
-#  define HAVE_U64_TYPEDEF
-# elif SIZEOF_UNSIGNED_INT == 8
+# else
+   /* make a best guess, could happen with UNIX98 <inttypes.h> */
+#  define U64_C(c) (c)
+# endif
+# define HAVE_U64_TYPEDEF
+#elif SIZEOF_UNSIGNED_INT == 8
 typedef unsigned int u64;
 #  define U64_C(c) (c ## U)
 #  define HAVE_U64_TYPEDEF

commit 620906643713e839b4a95714013ee4603fedc515
Author: Werner Koch <wk at gnupg.org>
Date:   Tue Nov 6 17:44:11 2012 +0100

    Indent nested cpp directives for better readability.
    
    --

diff --git a/include/types.h b/include/types.h
index d6cd073..7d93865 100644
--- a/include/types.h
+++ b/include/types.h
@@ -21,23 +21,22 @@
 #define G10_TYPES_H
 
 #ifdef HAVE_INTTYPES_H
-/* For uint64_t */
-#include <inttypes.h>
+# include <inttypes.h>   /* For uint64_t */
 #endif
 
 /* The AC_CHECK_SIZEOF() in configure fails for some machines.
  * we provide some fallback values here */
 #if !SIZEOF_UNSIGNED_SHORT
-#undef SIZEOF_UNSIGNED_SHORT
-#define SIZEOF_UNSIGNED_SHORT 2
+# undef SIZEOF_UNSIGNED_SHORT
+# define SIZEOF_UNSIGNED_SHORT 2
 #endif
 #if !SIZEOF_UNSIGNED_INT
-#undef SIZEOF_UNSIGNED_INT
-#define SIZEOF_UNSIGNED_INT 4
+# undef SIZEOF_UNSIGNED_INT
+# define SIZEOF_UNSIGNED_INT 4
 #endif
 #if !SIZEOF_UNSIGNED_LONG
-#undef SIZEOF_UNSIGNED_LONG
-#define SIZEOF_UNSIGNED_LONG 4
+# undef SIZEOF_UNSIGNED_LONG
+# define SIZEOF_UNSIGNED_LONG 4
 #endif
 
 
@@ -45,52 +44,52 @@
 
 
 #ifndef HAVE_BYTE_TYPEDEF
-#undef byte	    /* maybe there is a macro with this name */
-#ifndef __riscos__
+# undef byte	    /* maybe there is a macro with this name */
+# ifndef __riscos__
 typedef unsigned char byte;
-#else 
+# else
 /* Norcroft treats char  = unsigned char  as legal assignment
                but char* = unsigned char* as illegal assignment
    and the same applies to the signed variants as well  */
 typedef char byte;
-#endif
-#define HAVE_BYTE_TYPEDEF
+# endif
+# define HAVE_BYTE_TYPEDEF
 #endif
 
 #ifndef HAVE_USHORT_TYPEDEF
-#undef ushort     /* maybe there is a macro with this name */
+# undef ushort     /* maybe there is a macro with this name */
 typedef unsigned short ushort;
-#define HAVE_USHORT_TYPEDEF
+# define HAVE_USHORT_TYPEDEF
 #endif
 
 #ifndef HAVE_ULONG_TYPEDEF
-#undef ulong	    /* maybe there is a macro with this name */
+# undef ulong	    /* maybe there is a macro with this name */
 typedef unsigned long ulong;
-#define HAVE_ULONG_TYPEDEF
+# define HAVE_ULONG_TYPEDEF
 #endif
 
 #ifndef HAVE_U16_TYPEDEF
-#undef u16	    /* maybe there is a macro with this name */
-#if SIZEOF_UNSIGNED_INT == 2
+# undef u16	    /* maybe there is a macro with this name */
+# if SIZEOF_UNSIGNED_INT == 2
 typedef unsigned int   u16;
-#elif SIZEOF_UNSIGNED_SHORT == 2
+# elif SIZEOF_UNSIGNED_SHORT == 2
 typedef unsigned short u16;
-#else
-#error no typedef for u16
-#endif
-#define HAVE_U16_TYPEDEF
+# else
+#  error no typedef for u16
+# endif
+# define HAVE_U16_TYPEDEF
 #endif
 
 #ifndef HAVE_U32_TYPEDEF
-#undef u32	    /* maybe there is a macro with this name */
-#if SIZEOF_UNSIGNED_INT == 4
+# undef u32	    /* maybe there is a macro with this name */
+# if SIZEOF_UNSIGNED_INT == 4
 typedef unsigned int u32;
-#elif SIZEOF_UNSIGNED_LONG == 4
+# elif SIZEOF_UNSIGNED_LONG == 4
 typedef unsigned long u32;
-#else
-#error no typedef for u32
-#endif
-#define HAVE_U32_TYPEDEF
+# else
+#  error no typedef for u32
+# endif
+# define HAVE_U32_TYPEDEF
 #endif
 
 /****************
@@ -99,24 +98,24 @@ typedef unsigned long u32;
  * Solaris and IRIX.
  */
 #ifndef HAVE_U64_TYPEDEF
-#undef u64	    /* maybe there is a macro with this name */
-#if SIZEOF_UINT64_T == 8
+# undef u64	    /* maybe there is a macro with this name */
+# if SIZEOF_UINT64_T == 8
 typedef uint64_t u64;
-#define U64_C(c) (UINT64_C(c))
-#define HAVE_U64_TYPEDEF
-#elif SIZEOF_UNSIGNED_INT == 8
+#  define U64_C(c) (UINT64_C(c))
+#  define HAVE_U64_TYPEDEF
+# elif SIZEOF_UNSIGNED_INT == 8
 typedef unsigned int u64;
-#define U64_C(c) (c ## U)
-#define HAVE_U64_TYPEDEF
-#elif SIZEOF_UNSIGNED_LONG == 8
+#  define U64_C(c) (c ## U)
+#  define HAVE_U64_TYPEDEF
+# elif SIZEOF_UNSIGNED_LONG == 8
 typedef unsigned long u64;
-#define U64_C(c) (c ## UL)
-#define HAVE_U64_TYPEDEF
+#  define U64_C(c) (c ## UL)
+#  define HAVE_U64_TYPEDEF
 #elif SIZEOF_UNSIGNED_LONG_LONG == 8
 typedef unsigned long long u64;
-#define U64_C(c) (c ## ULL)
-#define HAVE_U64_TYPEDEF
-#endif
+#  define U64_C(c) (c ## ULL)
+#  define HAVE_U64_TYPEDEF
+# endif
 #endif
 
 typedef union {

-----------------------------------------------------------------------

Summary of changes:
 include/types.h |   90 ++++++++++++++++++++++++++++--------------------------
 1 files changed, 47 insertions(+), 43 deletions(-)


hooks/post-receive
-- 
The GNU Privacy Guard
http://git.gnupg.org




More information about the Gnupg-commits mailing list