1.0.1 config problems was (1.0.0 configure problems)

EDEN, ROBERT (SWBT) RE8650 at txmail.sbc.com
Thu Dec 16 09:12:13 CET 1999

I just tried to build 1.0.1 on solaris and encounted this old problem.

To work around I had to add gdbm to Paul's solution.
	make LIBS='-ldl -lnsl -lsocket -lintl -lgdbm'


-----Original Message-----
From: Paul D. Smith [mailto:pausmith at nortelnetworks.com]
Sent: Friday, September 24, 1999 1:03 PM
To: gnupg-devel at gnupg.org
Subject: 1.0.0 configure problems

First, a nit: please don't add flags to the GCC compile line until near
the end of the configure process; otherwise many of the little test
programs will generate warnings that can cause some tests to fail... or
at least confuse people looking at config.log.  E.g., move this:

  if test "$GCC" = yes; then
      CFLAGS="$CFLAGS -Wall -Wcast-align -Wshadow -Wstrict-prototypes"

near the end of configure.in, just before the AC_OUTPUT stuff (or
whatever's appropriate).

Second, I have GNU gettext installed on my system, but in a non-standard
place.  I'm using GCC/GNU make on Solaris 2.5.1.

Configure locates it OK:

  checking for LC_MESSAGES... yes
  checking whether NLS is requested... yes
  checking whether included gettext is requested... no
  checking for libintl.h... yes
  checking for gettext in libc... no
  checking for bindtextdomain in -lintl... yes
  checking for gettext in libintl... checking for gettext in -lintl... yes
  checking for msgfmt... /usr/global/bin/msgfmt
  checking for dcgettext... no
  checking for gmsgfmt... /usr/global/bin/msgfmt
  checking for xgettext... /usr/global/bin/xgettext
  checking for catalogs to be installed...  de es_ES fr it pl pt_BR ru

and notices that I need to link -lintl in order to get stuff like

But, then the makefiles don't have that info and the link fails:

  /bin/sh ../libtool --mode=link gcc  -O2 -Wall -Wcast-align -Wshadow
-Wstrict-prototypes -L/usr/global/lib -R/usr/global/lib -o mpicalc
mpicalc.o ../cipher/libcipher.la              ../mpi/libmpi.la
../util/libutil.la  -lz -ldl -lnsl -lgdbm  -lsocket
  mkdir .libs
  gcc -O2 -Wall -Wcast-align -Wshadow -Wstrict-prototypes -L/usr/global/lib
-o mpicalc mpicalc.o ../cipher/.libs/libcipher.a -lz -ldl -lnsl -lgdbm
-lsocket ../mpi/.libs/libmpi.a -lz -ldl -lnsl -lgdbm -lsocket
../util/.libs/libutil.a -lz -ldl -lnsl -lgdbm -lsocket -lz -ldl -lnsl -lgdbm
-lsocket -R/usr/global/lib -R/usr/global/lib
  Undefined                       first referenced
   symbol                             in file
  bindtextdomain                      mpicalc.o  (symbol belongs to implicit
dependency /usr/lib/libintl.so.1)
  gettext                             ../util/.libs/libutil.a(logger.o)
(symbol belongs to implicit dependency /usr/lib/libintl.so.1)
  textdomain                          mpicalc.o  (symbol belongs to implicit
dependency /usr/lib/libintl.so.1)
  ld: fatal: Symbol referencing errors. No output written to mpicalc

Note there's no -lintl anywhere here.

If I run "make LIBS='-ldl -lnsl -lsocket -lintl'" (Solaris needs the
first three) then it links OK.  I can't figure out where this is
_supposed_ to go.  In tools/Makefile I see:


but they're all empty... and AFAICT none of them (like INTLLIBS) is
referred to by any make macro that actually gets passed on the link
line anyway.

So, something is missing here.

Note I have built other GNU packages with my current gettext setup and
it has worked... FWIW.

 Paul D. Smith <psmith at baynetworks.com>         Network Management
 "Please remain calm...I may be mad, but I am a professional." --Mad
   These are my opinions---Nortel Networks takes no responsibility for them.

More information about the Gnupg-devel mailing list