Many Problems Building GnuPG

Jim Seymour jseymour at
Fri Feb 12 18:09:50 CET 1999

> Date: Fri, 12 Feb 1999 12:41:25 +0100
> Message-ID: <19990212124125.E16155 at>
> From: Werner Koch <wk at>
> Subject: Re: Many Problems Building GnuPG
> Jim Seymour <jseymour at> writes:
> > During whatever's happening after that point, CPU usage goes to
> > 100%, load starts climbing (up to 16 before I kill the thing),
> The EGD will help.

Okay.  Should I wait before trying further until this is in?

> > As regards the bus error in tiger_init(): excuse my ignorance,
> Hmmm it works right even on the alpha but I check it again there.

Perhaps I'll further-acquaint myself with the use of gdb and see
if I can't provide more definitive data on why it's bus-error'ing.

> > but I noticed several of these in tiger.c.  How can a function
> > be defined to take an argument, as in "TIGER_CONTEXT *hd" yet
> > none of the calls to these routines pass them anything???  I've
> It gets called by a fucntion pointer from md.c

Doh.  Perhaps if I read more of the code I would've figured that
out, eh?

> > is set up to handle the Sun commercial development system.  And
> > I'm hampered by being quite "configure-clueless" :-(.
> I did some fixes for these environment (include/types.h if I remember
> correct) but there might be a problem with make.  I have not yet figured
> out what's the reason as automake should generate standard makefiles.
> Maybe this gets fix with automake 1.4 which I installed yesterday.

I wonder if part of the problem is this: for whatever reason (I no
longer remember) a co-admin of mine had a problem with GNU make and
renamed it to gmake.  So when I run "make", I actually have to run
"gmake" if I want the GNU make.  But that doesn't *appear* to be the
major problem.  I run into things like problems with "-O2" and "-Wall",
which the Sun devsys compiler doesn't accept.

I'll stay subscribed to the list to watch developments.  But other than
maybe taking a shot at seeing if I can't debug the bus error problem on
the system here at home, I'll suspend further attempts until some of
the new stuff you've mentioned here is in place.

Guess I'm stuck with PGP for a while.  <shrug>

Thanks for the follow-up.

Jim Seymour                  | PGP Public Key available at:
jseymour at  | |

More information about the Gnupg-devel mailing list