0.9.3: import (secret key) and delete-key problem

Rich Wales richw at webcom.com
Sun Feb 21 00:09:15 CET 1999

I'm using 0.9.3, and I'm also using the RSA and IDEA extensions for the
sake of experimentation.  (My home PC is running FreeBSD 2.2.8.)

I tried to import an RSA key pair.  (I did this previously, without any
difficulty, under 0.9.2.)

I imported the public key OK, but I couldn't import the secret key.  I
kept getting messages such as the following:

  gpg:[stdin]: key A6A59DB9: secret key not found: public key not found
  gpg:[stdin]: read error: public key not found
  gpg: Total number processed: 0
  gpg:       secret keys read: 1
  gpg: import failed: public key not found

I tried importing the secret key both with an "empty" passphrase (as
described in Caskey Dickson's instructions) and with the passphrase
intact (which seemed to work fine under 0.9.2 once I installed the RSA
extension code).  Neither way worked.

I then tried to delete the public key (in order to start over fresh),
but this wouldn't work either.  I got the following error:

  gpg: 0a6a59db9: get secret key: public key not found

After beating my head against the wall (figuratively speaking) for about
an hour, I decided to go back to using 0.9.2 -- whereupon everything
worked like a charm.

So, it would appear that something in the keyring management routines
broke between 0.9.2 and 0.9.3.  Any ideas?

I'm not sure, BTW, why the problem arose.  I suppose it could be any of
the following:

    ==> the fact that the key was an RSA key generated by PGP 2.6.x
    ==> the fact that the key ID started with a letter (even though
	I escaped it on the command line with a leading zero)
    ==> the fact that the key ID's high order bit was a 1
    ==> some weird bug triggered by this particular key ID
    ==> something else entirely?

Rich Wales         richw at webcom.com         http://www.webcom.com/richw/

More information about the Gnupg-devel mailing list