GPG fails to recognize PGP 6.5.2 keys

Hugh Daniel hugh at
Fri Oct 13 17:48:08 CEST 2000


  What?  An opption to suppress what looks like total failure message?
You have to be joking!  Surely you can't be thinking that your average
user can deal with this sort of cruft, can you?
  Even your average sysadmin is going to have fits over this, let
alone what the poor fools that have to code GUI's around it.

  Even if you think spitting out random bitches is 'cool', this error
message stunk.  Since gpg does not even have a non-invasive way of
inspecting PGP blobs I had no idea what the KEY ID was, and presumed
that the error message was about the key blob I had told it to work
  What is GPG doing mucking with my secret keys anyway, I told it to
import a public key!
  The skipped part would indicate that my key blob was ignored.
Worse, if your into the wordy style of messages, then it should have
given me 10 lines of useless info on the key blob it was working on.
  Witness what happens with I run the command this way:

hugh at road $ gpg --verbose --import bar ; echo $?
gpg: armor header: Version: PGPfreeware 6.5.2 for non-commercial use <>
gpg: pub  1024D/BAFC4008 2000-08-10   Lisa Haskel <lisa at>
gpg: key 6E720A51: secret key without public key - skipped

  The ONLY assurance I have that something worked is the "0" return
value, thats presuming that "6E720A51" is not a corruption of
"1024D/BAFC4008".  So what good is --verbose?  Some, but verry little.

  Maybe what you want is a --lint or --housekeeping option that can be
run by GUI's and sysadmins to check on weird stuff like this.  Better
yet we could do --pedantic just for fun!

  Look, I _want_ GPG to be good and useful, but every time I try it
it's got so many warts that I go back to using PGP2 within a day if
not hour.  Werner can attest that I have bugged him on lots of stuff
(can't fix any of it as I am a USSA citizen/slave_unit of my Lord
Clinton...) over the last 18 months, I have done what I can and this
bitchy message is what I am 'free' to do to help.

  The current problem is minor compaired to the fact that something
like half the messages I try sending with GPG can not be read by other
PGP's out there, no matter what options I try.  Until this program
works like a real Unix program and inter-operates with other of it's
kind on the net its just not useful.

		||ugh Daniel
		hugh at

			Systems Testing & Project mis-Management
			The Linux FreeS/WAN Project

Version: 2.6.3i
Charset: noconv


More information about the Gnupg-devel mailing list