More key expiration problems

Rich Wales richw at
Fri Sep 1 18:17:26 CEST 2000

A followup to my message from yesterday:

One of the problems I noticed was that the primary key ended up with
a 90-day lifetime, even though I specified that the primary key should
never expire when I created it.  (I did specify a 90-day lifetime for
the subkey which was created at the same time as the primary key.)

I tried to delete the expiration time for the primary key, using
"gpg --edit-key 0xa0301298" and the "expire" editing command.  The
program took me through the dialogue for specifying an expiration
time (I chose the default value, 0, meaning the key shouldn't expire
at all).  However, the command ended up having no effect -- I wasn't
asked for my pass phrase, and the primary key still displayed its
original expiration date.  When I said "save", the program simply
exited without making any changes at all.

Similarly if I tried to set a non-zero (but different) expiration
time on the primary key -- it simply didn't happen.  I was, however,
able to change the expiration time of one of my subkeys.

Rich Wales         richw at

More information about the Gnupg-devel mailing list