Bug report: send-keys doesn't work with transparent http proxy server

Peter Surda shurdeek at panorama.sth.ac.at
Tue Aug 21 11:47:02 CEST 2001


I want to report a bug, gpg 1.0.5 and 1.0.6 don't work with --send-keys when a
transparent proxy is in the way (squid in my case). 

I tried to intercept the traffic with ethereal, and got different results.
Sometimes, gpg seems to cut the connection before the other end can reply,
sometimes simply an error response returns, but gpg reports "success,

When I did export http_proxy=whatever and used --honor-http-proxy, the problem
vanished. Also, getting keys, whether manually with --get-key or automatically
when reading signed emails within mutt, gpg works ok.

I am not sure what the exact problem is. gpg is the ONLY program having
problems with this transparent proxy, we have a network with over 450
computers runing numerous operating systems and none of the http clients ever
had problems, AFAIK.

Hmm, now something strange happened: it suddenly seems to work, only
www.keyserver.net has problems with transparent proxy. But about an hour ago,
neither certserver.pgp.com nor wwwkeys.eu.pgp.net worked without
--honor-http-proxy. This is weird.

Could someone who has a transparent proxy check this? Or if you have
questions, tell me what to test and I'll post the results.

Also, please cc me, I'm not on the list and don't plan to subscribe.


Peter Surda (Shurdeek) <shurdeek at panorama.sth.ac.at>, ICQ 10236103, +436505122023

            The dark ages were caused by the Y1K problem.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 240 bytes
Desc: not available
Url : /pipermail/attachments/20010821/ec0b9b38/attachment.bin

More information about the Gnupg-devel mailing list