Compilation Problems on AIX 4.3.3

Leif E. Olson lolson at
Thu Jun 14 16:50:02 CEST 2001

On Thu, 14 Jun 2001 gnupg-devel at wrote:

> Date: Thu, 14 Jun 2001 00:32:44 -0500
> From: gnupg-devel at
> Reply-To: gnupg-devel at
> To: The Raven <raven at>
> Cc: gnupg-devel at
> Subject: Re: Compilation Problems on AIX 4.3.3
> On Thu, Jun 07, 2001 at 10:40:57AM -0500, The Raven wrote:
> > I am having trouble compiling GnuPG on AIX 4.3.3 on a 64-bit IBM RS6000
> > with gcc 2.95.3 and make 3.79.1.
> > I have tried almost every combination of configure options.  One being:
> > /configure --disable-asm --enable-static-rnd=unix  --disable-nls
> > --with-included-zlib --with-included-gettext --disable-dynload
> Worked fine for me with the IBM C compiler (with --disable-asm). I had
> the same problem as you below with GCC.
> -- 
> albert chin (china at

Unfortunately, I jumped the gun with my question.  I figured out my
problem soon after by just reading further down the INSTALL file:

        Due to a change in gcc (since version 2.8) the MPI stuff may
        not build. In this case try to run configure using:
            CFLAGS="-g -O2 -mcpu=powerpc" ./configure

Perhaps since this is known about it could be included in the configure?


More information about the Gnupg-devel mailing list