gpgme assert crash during op_encrypt_sign

J Robert Ray jrray at
Wed Aug 21 00:20:01 CEST 2002

Hash: SHA1

Marcus Brinkmann wrote:
| Can you please try out the following change:
| 2002-08-20  Marcus Brinkmann  <marcus at>
|         * gpgme.c (_gpgme_set_op_info): Append data on subsequent calls.
|         * encrypt-sign.c (encrypt_sign_status_handler): Remove op_info
|         handling.
| Just try the latest CVS while you are at it :)  Can't harm (except if you
| rely on the import function, which we will fix later today).

Thank you for the quick patch, it does indeed prevent the assert, but
now I have I much more insidious problem.

1) First I sign a key and set the trust level for it to full.

2) I test the trustdb by running "gpg -r <keyid> -a --encrypt" and
verify that gpg does not prompt me that the key is untrusted.

3) Then, I run my test program, it fails to encrypt_sign to this key,
returning no valid recipients.

4) I quit out of my test program and try to test the trustdb again as in
step 2, this time gpg tells me the key is untrusted.

Once I run "gpg --update-trustdb" the test in step 2 begins to work
again.  But step 3 always fails.

This leads me to suspect gpgme is corrupting the trustdb somehow.  Sorry
if this is a wild accusation. :)

Could this be an artifact of using gpgme_recipients_add_name()?  I read
that using this function is the same as adding with VALIDITY_UNKNOWN.
What I want to happen is to not indicate a trust/validity level at all
and defer to gpg's trustdb.

- - Robert

- --
Key fingerprint = BEA9 490C D2B9 AD83 E88B  3148 3136 34E4 BB92 9E54
Version: GnuPG v1.1.90-nr1 (Windows XP)
Comment: Using GnuPG with Mozilla -


More information about the Gnupg-devel mailing list