Installation problems...

Strawn, Eric R. Eric.Strawn at
Thu Jun 13 19:36:01 CEST 2002

First, I have to thank Max and Albert for their suggestions.  I'm making

I was able to run the configure by executing the following command:

CC=path CFLAGS='-O2 -pipe' ./configure

where the path value is the location of your compiler (in my case, the gcc
compiler).  When I ran this (again, on HPUX-11i) it ended without any fatal
errors.  I then went and ran 'make' but came across the syntax error shown

Making all in keyserver
Making all in po
Making all in doc
Make: line 180: syntax error.  Stop.
*** Error exit code 1

When I checked in the /doc subdirectory at the Makefile and
objects at that particular line (180), I found:

: gpg.texi
gpg.dvi: gpg.texi gpgv.texi
gpgv.dvi: gpgv.texi

I changed the first line to be commented (#) though I'm not sure that is
correct.  Should it be the following?: gpg.texi

I checked the bugs webpage but did not see any reports of this syntax error.
I then ran 'make' again but came up with the following error:

Making all in checks
No suffix list.
        echo '#!/bin/sh' >./gpg_dearmor
        echo "../g10/gpg --no-options --no-greeting \
                     --no-secmem-warning --batch --dearmor" >>./gpg_dearmor
        chmod 755 ./gpg_dearmor
        ./gpg_dearmor > ./pubring.gpg < ./pubring.asc
        ./gpg_dearmor > ./secring.gpg < ./secring.asc
        ./gpg_dearmor > ./plain-1 < ./plain-1o.asc
        ./gpg_dearmor > ./plain-2 < ./plain-2o.asc
        ./gpg_dearmor > ./plain-3 < ./plain-3o.asc
        ./gpg_dearmor > ./pubring.pkr < ./pubring.pkr.asc
        ./gpg_dearmor > ./secring.skr < ./secring.skr.asc
        cat ./ >./options
        ../tools/mk-tdata   500  >data-500
        ../tools/mk-tdata  9000  >data-9000
        ../tools/mk-tdata 32000  >data-32000
        ../tools/mk-tdata 80000  >data-80000
        cat ./../doc/HACKING \
            ./../doc/DETAILS \
            ./../doc/FAQ         >plain-large
        ../g10/gpg --homedir . --quiet --yes --import ./pubdemo.asc      
gpg: ../cipher/tiger: not a gnupg extension: Unable to find library

Does anyone know if these are related?  Or absolutely unrelated?  I did
check on the library and it does NOT exist.  The only related objects in the
/usr/lib/nls/loc/pa20_64/locales.2/ directory that I see are C.iso88591,
C.iso885915 and C.utf8 which are all executables.

Any clues as to what the problem may be (besides the person doing the
install which is me!?!?!)?  Any info again would be greatly appreciated.
Thanks in advance...

-----Original Message-----
From: Max V. Zinal [mailto:Zlat0 at]
Sent: Wednesday, June 12, 2002 2:32 PM
To: Eric.Strawn at
Cc: GnuPG developers mailing list
Subject: Re: Installation problems...

Strawn, Eric R. wrote:

>Obviously I'm missing something.  I've gotten GCC installed with no
>problems.  But when I run configure I'm still getting the same errors.  Do
I need to add some options to the configure?  Has anyone installed GnuPG on
HPUX-11i before?  Any info would be greatly appreciated.  The log is below.
I have never installed GnuPG under HP-UX, but these error messages seem 
very familliar to me. I saw something like that when I tried to compile 
some portions of GNU software. I think you could try something like
    CC=gcc CFLAGS='-O2 -pipe' ./configure [...]
in your Bourn-style shell. Also make shure that gcc precedes cc in your 

Usually autoconf saves us a lot of time. But it is really brain-damaged 
in some aspects, so a `bad' situation may cause it to become a problem 

I hope this can help you. Best regards,
    Max V. Zinal
    Zlat0 at
    "A common narrow-minded man is much more dangerous than a complete 
idiot: he can often reach a senseless goal with keen and complex means, 
so his opponents, and even his friends can never be safe".

More information about the Gnupg-devel mailing list