Problems with make on HP-UX 10.20

Albert Chin gnupg-devel at
Tue Jun 18 22:54:02 CEST 2002

On Mon, Jun 17, 2002 at 03:31:13PM -0400, Casey, Brian A. wrote:
> Thank you very much, Albert.  I ran configure with --disable-dynload and was
> then able to run "make" successfully, though I had two types of warnings:
> "Pointers are not assignment-compatible"
> "Argument #1 is not the correct type"


> I have two further questions.  First, are these warnings anything to worry
> about?  Second, I am now having trouble with "make check".  I have 20 of 25
> tests failing, then the following output:
> make[2]: *** [check-TESTS] Error 1                                     
> make[2]: Leaving directory `/usr/local/gnupg/gnupg-1.0.7/checks'       
> make[1]: *** [check-am] Error 2                                        
> make[1]: Leaving directory `/usr/local/gnupg/gnupg-1.0.7/checks'       
> make: *** [check-recursive] Error 1                                    
> What do I need to do before I move on to the "make install"?

Is EGD/PRNGD running on the correct socket when you run 'make check'?
I just ran 'gmake check' here on our 10.20 box and I had 20/25 tests
fail. When I ran PRNGD to listen on the path specified with
--with-egd-socket, the 20 tests succeeded.

I note in a previous email you installed EGD. Install PRNGd instead:

albert chin (china at

More information about the Gnupg-devel mailing list