problem with using files as a keyring

lego lego legoxx at
Thu Mar 7 11:48:01 CET 2002


i'm trying this from the doc/DETAILS

$ cat >foo <<EOF
     %echo Generating a standard key
     Key-Type: DSA
     Key-Length: 1024
     Subkey-Type: ELG-E
     Subkey-Length: 1024
     Name-Real: Joe Tester
     Name-Comment: with stupid passphrase
     Name-Email: joe at
     Expire-Date: 0
     Passphrase: abc
     %secring foo.sec
     # Do a commit here, so that we can later print
"done" :-)
     %echo done
$ gpg --batch --gen-key -a foo
$ gpg --no-default-keyring --secret-keyring foo.sec \

but instead of this output:
sec  1024D/915A878D 2000-03-09 Joe Tester (with stupid
passphrase) <joe at>
ssb  1024g/8F70E2C0 2000-03-09

i just got this:
gpg: Warning: using insecure memory!
gpg: /home/peter/.gnupg/foo.sec: keyring created
gpg: /home/peter/.gnupg/ keyring created

i tried to sign files using foo.sec but it won't work
it seems that the keyrings are not even open...

well when i run 

gpg --no-default-keyring --secret-keyring foo.sec
--keyring --list-secret-keys

for second time i got not output at all just

gpg: Warning: using insecure memory!
[peter at love1 foo]$
i want to sign a file without importing key to my
keyring, and i need my customer to verify signature
without installing public key to his keyring. Just
simple command line interface. Ideally in batch file

i want to use and foo.sec in the current
direcotory not /home/user/.gnupg

so i modified my script:gpg --no-default-keyring
--secret-keyring ./foo.sec --keyring ./

but i got this...

gpg: Warning: using insecure memory!
gpg: [don't know]: invalid packet (ctb=2d)
gpg: read_keyblock: read error: invalid packet
gpg: enum_keyblocks(read) failed: invalid keyring

can anyone help me please?

Do You Yahoo!?
Try FREE Yahoo! Mail - the world's greatest free email!

More information about the Gnupg-devel mailing list