GPG 1.1.92 bogus error for IDEA plugin

Larry Ellis Larry_C_Ellis at
Thu Sep 12 22:48:01 CEST 2002

> On Thu, Sep 12, 2002 at 10:16:29AM -0500, Larry Ellis wrote:
> > When I run --version on 1.1.92, IDEA is missing from the cipher list.
> I suspect you are using the IDEA plugin from 1.1.90 with 1.1.92.  That
> won't work.  Did you see an error message ("invalid module `......')
> when you ran gpg?

No.  It simply says the plugin is not present.

This is the Windows version, incidentally.  Has the method of specifying
plugins in the options file changed?  I have tried all of the following with
no difference or improvement:

load-extension Lib\idea
load-extension c:\gnupg\Lib\idea
load-extension c:/gnupg/Lib/idea
load-extension idea

And, I have tried these both with the 1.1.90 precompiled idea module
distributed on *and* with my own compiled version of the
module using the source code you referenced.  Admittedly, I used the nullify
make file for this, but, frankly, in comparing the source, I could see no
huge differences in the two versions of idea.c that might explain the
failure.  Of course, I could be missing something.

With 1.1.90,  IDEA is listed in the cipher spec with --version even if the
idea.dll is not present.  No failure occurs until I actually attempt to
encrypt something.  With 1.1.92, I haven't managed to get IDEA referenced in
the cipher spec list (as reported in --version).

My install directory is c:\gnupg, as you might gather from the above.  In
addition, I updated the registry using the gnupg.reg file supplied with the
Windows build.

Any other ideas (no pun intended).

More information about the Gnupg-devel mailing list