Problems with GNUpg 1.2.2 on AIX 5.2.0 (ML 1)

Martinez, Jeffery JM SITI-ITDGA Jeffery.Martinez at
Sat Aug 2 10:53:02 CEST 2003

I have not been able to get the GNUpg 1.2.2 to work with AIX 5.2 using the
/dev/random device to pull random information.  The program is not able to
gather enough data and just sits there waiting forever for more random data
to appear:

 # ./gpg --gen-key            
gpg (GnuPG) 1.2.2; Copyright (C) 2003 Free Software Foundation, Inc.
This program comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it
under certain conditions. See the file COPYING for details.

Please select what kind of key you want:
   (1) DSA and ElGamal (default)
   (2) DSA (sign only)
   (5) RSA (sign only)
Your selection? 
DSA keypair will have 1024 bits.
About to generate a new ELG-E keypair.
              minimum keysize is  768 bits
              default keysize is 1024 bits
    highest suggested keysize is 2048 bits
What keysize do you want? (1024) 
Requested keysize is 1024 bits   
Please specify how long the key should be valid.
         0 = key does not expire
      <n>  = key expires in n days
      <n>w = key expires in n weeks
      <n>m = key expires in n months
      <n>y = key expires in n years
Key is valid for? (0) 
Key does not expire at all
Is this correct (y/n)? y
You need a User-ID to identify your key; the software constructs the user id
from Real Name, Comment and Email Address in this form:
    "Heinrich Heine (Der Dichter) <heinrichh at>"

Real name: Root user
Email address: root at hostname
Comment: Root user         
You selected this USER-ID:
    "Root user (Root user) <root at hostname>"

Change (N)ame, (C)omment, (E)mail or (O)kay/(Q)uit? o
You need a Passphrase to protect your secret key.    

Not enough random bytes available.  Please do some other work to give
the OS a chance to collect more entropy! (Need 16 more bytes)


I ran some quick tests with dd on the /dev/random device to see if it was
generating data and it appears to be generating data just fine--especially
for something just waiting for 16 more bytes).  I used the command:

dd if=/dev/random of=/tmp/junkfile

Do you know of anyone who has been able to successfully compile and run
GNUpg on AIX 5.2 to encrypt files and generate keys using /dev/random?  On a
similar system I tried installing an AIX 5.2 (ML1) APAR fix related to
/dev/random which installed an updated fileset for to
version now on this server I receive an out of memory error
when I run a command to encrypt a file.

I would greatly appreciate any help/advice you can offer.


Jeffery Martinez

Shell Information Technology International
P.O. Box 20329, Houston, TX 77025-0329, United States of America

Tel: +1 713-245 2774
Email: Jeffery.Martinez at

More information about the Gnupg-devel mailing list