proxy authentication - i presume it doesn't work.

jonathan soong jon.soong at
Mon Aug 4 06:25:02 CEST 2003

Hi everyone,

I'm trying to get gpg to work through an Authenticating Squid proxy, 
with not much luck. I am presuming it is broken.
Below are the steps i have tried:

If i use a non-authenticating Squid proxy, it works fine (i needed the 
'broken-http-proxy' option),
however authenticating Squid proxies don't seem to work.

I have tried setting the proxy username/password in the http_proxy 
    $> export http_proxy=

    I receieve:

   $> ./gpg --keyserver-options "honor-http-proxy broken-http-proxy" 
--keyserver=XXX.XXX.XXX.XXX --search-keys haze01
    gpg: searching for "haze01" from HKP server
    gpg: agent: host not found: ec=11001
    gpg: can't search keyserver: No such file or directory

And i have tried to set the http_proxy_username and http_proxy_password 
environment variables:
    $> export https_proxy_password=agent
    $> export http_proxy_password=agent
    $> export https_proxy_username=agent
    $> export http_proxy_username=agent
    $> export http_proxy=
    I receive:

    $> $ ./gpg --keyserver-options "honor-http-proxy broken-http-proxy" 
--keyserver= --search-keys haze01
        gpg: searching for "haze01" from HKP server
        gpg: key "haze01" not found on keyserver
      And in the squid logs: - - [04/Aug/2003:12:52:28 +0930] "GET 
http://XXX.XXX.XXX.XXX:11371/pks/lookup? HTTP/1.0" 407 1773 TCP_DENIED:NONE

    So i presume it is not getting authenticated at all.

If anyone has any suggestions or advice i'd be most grateful.

If not, my next plan is to write something to send the public keys over 
normal HTTP and write a script on the other end to
upload a key to a keyserver.

Kind Regards


More information about the Gnupg-devel mailing list