1.3.1 cross compile error

venona at gmx.ch venona at gmx.ch
Mon Mar 24 10:05:02 CET 2003

On Sat, 22 Mar 2003 19:04:10 -0500, David Shaw <dshaw at jabberwocky.com> wrote:

> > gpgkeys_hkp.c:21: config.h: No such file or directory
> It sounds like your -I include paths are not pointing where they need
> to point.

After gpg.exe was generated I ran the following command:
/usr/src/gnupg-1.3.1/keyserver$ source='gpgkeys_hkp.c' object='gpgkeys_hkp.o' 
libtool=no \
depfile='.deps/gpgkeys_hkp.Po' tmpdepfile='.deps/gpgkeys_hkp.TPo' \
depmode=gcc /bin/sh /usr/src/gnupg-1.3.1/scripts/depcomp \
/usr/local/lib/mingw32-cpd/bin/i386--mingw32-gcc -DHAVE_CONFIG_H -I. 
-I/usr/src/gnupg-1.3.1/keyserver -I/usr/src/gnupg-1.3.1 
-I/usr/src/gnupg-1.3.1/include -I/usr/src/gnupg-1.3.1/intl 
-g -O2 -Wall -c `test -f 'gpgkeys_hkp.c' || echo './'`gpgkeys_hkp.c

Then the foolowing message appeared:
gpgkeys_hkp.c: In function `main':
gpgkeys_hkp.c:746: warning: implicit declaration of function `getopt'
gpgkeys_hkp.c:761: `optarg' undeclared (first use in this function)
gpgkeys_hkp.c:761: (Each undeclared identifier is reported only once
gpgkeys_hkp.c:761: for each function it appears in.)
gpgkeys_hkp.c:772: `optind' undeclared (first use in this function)

and the build of gpgkeys_hkp.exe failed.

When I copied errors.h, iobuf.h, util.h,  http.h, keyserver.h, mpi.h,
and types.h to "keyserver" directory and ran the following command,
the same error message appeared.

/usr/src/gnupg-1.3.1/keyserver$ /usr/local/lib/mingw32-cpd/bin/i386--mingw32-gcc 
-DHAVE_CONFIG_H -I/usr/src/gnupg-1.3.1 -I/usr/src/gnupg-1.3.1/keyserver 
-I/usr/src/gnupg-1.3.1/include -g -O2 -Wall gpgkeys_hkp.c -o gpgkeys_hkp.exe

On the other hand, the executable gpgkeys_hkp for linux was built
with no problem.

Does this mean that the build of gpgkeys_hkp.exe is impossible at all?
Or do I fail to notice anything important?
Any suggestion will be appreciated.

More information about the Gnupg-devel mailing list