1.2.2 on HP-UX

David Ellement ellement at sdd.hp.com
Wed May 14 04:30:02 CEST 2003

On 2003-05-12, David Shaw wrote
> On Mon, May 12, 2003 at 11:44:54AM -0500, Anthony Kim wrote:
> > gnupg-1.2.2 fails to build on HP-UX at cipher/random.c:
> > 
> > random.c: In function `fast_random_poll':
> > random.c:655: storage size of `buf' isn't known
> > random.c:656: warning: implicit declaration of function `times'
> > random.c:655: warning: unused variable `buf'
> This is actually an autoconf bug.  Presumably it will be fixed soon.
> In the meantime, the upcoming 1.2.3 release of GnuPG can handle this
> and will build correctly.

When I ran into this, I tried re-running aclocal, autoheader, automake,
and autoconf.  I got a version of configure that correctly detected that
'gettimeofday', 'clock_gettime', and 'setrlimit' are available (they
failed with the original configure), but it failed to build the Makefile
in the po directory.

David Ellement

More information about the Gnupg-devel mailing list