Problems envrypting and sending signed e-mail.

Jose Carlos dos Santos Danado jcd at
Mon May 3 17:07:58 CEST 2004


I am trying to use cryptplug, specially the smime plug-in, in the kmail.
I am using KDE and KDE-PIM 3.1.1.

gpg 1.2.2
gpgme 0.3.15
newpg 0.9.4
libgcrypt 1.1.12
libksba 0.4.6
cryptplug 0.3.15
pinentry 0.6.8

The packages used are similar to the ones used in SUSE 8.2. (Tell me if
I am missing some package).

I have started the gpg-agent with:
eval `gpg-agent --daemon`

in the startkde script. I have also added the following configuration to

In the ~/.gnupg/gpgsm.conf, I have the following configuration:
agent-program /usr/bin/gpg-agent
dirmngr-program /usr/bin/dirmngr
#disable-crl-checks # uncomment if you think it is appropriate
#disable-policy-checks # uncomment if you think it is appropriate

In the ~/.gnupg/gpg-agent.conf, I have the following configuration:
pinentry-program /usr/bin/pinentry-qt
default-cache-ttl 600

After doing all this, I have added CA and my own certificates with gpgsm
as described in the aegypten project. I have used openssl has described.

I have added smime plugin in the kmail. However, when I tried to sign an
email, I always get an error saying that the e-mail in the certificate
is not the same has the one in the message. I have checked this and the
name that I am using in Kmail message and certificate are the same. But
I tried to sign the email anyway and following that, I got another error
from the kmail with #22 Invalid engine.

Has anyone experienced this problem? Does anyone had the same
experience? I have no clues how to solve this problem. I need to have
kmail to sign and encrypt messages but I don't know how to solve this.

If anyone of you guys know the answer to this problem, if possible send
an answer to this mailing list with my e-mail in bcc. I really need the

Thanks for your time.

Best regards,
Jose Carlos

More information about the Gnupg-devel mailing list