Building 1.3.92 (and maybe 1.4.0) for Win32

Carlo Luciano Bianco clbianco at
Fri Nov 19 01:41:53 CET 2004

Carlo Luciano Bianco <clbianco at> wrote:

> Now I tried also to check the libutil.a:
> ------------------------------------------------
> $ strings -a util/libutil.a | grep "vas"
> _libintl_vasprintf
> _libintl_vasprintf
> vasprintf() failed
> _vasprintf
> ------------------------------------------------
> So it seems that the vasprintf function has been correctly compiled in
> the library... Can this be a gcc problem not finding it when linking?
> And what is _libintl_vasprintf? Should it be used instead of plain
> _vasprintf? 

Well... I tried and if I change the "vasprintf" occurrences in ttyio.c
into "libintl_vasprintf" everything works. 

Moreover, Joe Vender pointed out to me that this problem does not happen
at all if I do a "-static" build. I checked and the building process works
correctly also with the unpatched ttyio.c. 

So it seems a MinGW gcc and/or ld problem (or, at least, of their
configuration)... :-/ 

By the way, do you think it is correct to change "vasprintf" into
"libintl_vasprintf" in ttyio.c? Beside the compilation, also "make check"
seems ok... 

Thank you all for your help!

| Carlo Luciano Bianco | ICQ UIN: 109517158                              |
|______________________| Home page: <>    |
|GPG DSA/ElG 1024/4096:|_________________________________________________|
|KeyID:0x5324A0DA - Fingerprint:8B00C61034120506111B143DEDBF71B45324A0DA |

More information about the Gnupg-devel mailing list