Cross compilation of gpgme on Fedora Core 4

Srinivasan S ssrini at
Tue Oct 25 19:02:37 CEST 2005

Hi Werner

With the svn trunk the compilation goes through fine .. I now get the following error:

make  all-recursive
make[1]: Entering directory `/home/ssrini/temp/cvs/gpgme'
Making all in gpgme
make[2]: Entering directory `/home/ssrini/temp/cvs/gpgme/gpgme'
make  all-am
make[3]: Entering directory `/home/ssrini/temp/cvs/gpgme/gpgme'
/bin/sh ../libtool --mode=compile no `echo -DHAVE_CONFIG_H -I. -I. -I..  | sed -e 's/-I/--include-dir /g;s/-D/--define /g'` -i versioninfo.rc -o versioninfo.lo
 no --define HAVE_CONFIG_H --include-dir . --include-dir . --include-dir .. -i versioninfo.rc -o versioninfo.o
../libtool: line 1170: no: command not found
make[3]: *** [versioninfo.lo] Error 1
make[3]: Leaving directory `/home/ssrini/temp/cvs/gpgme/gpgme'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/ssrini/temp/cvs/gpgme/gpgme'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/ssrini/temp/cvs/gpgme'
make: *** [all] Error 2

I tried to manually edit the Makefile and set the proper libtool command but failed.  the versioninfo.rc is not compiling ..

Your help is greatly appreciated

----- Original Message -----
From: "Werner Koch" <wk at>
To: "Srinivasan S" <ssrini at>
Subject: Re: Cross compilation of gpgme on Fedora Core 4
Date: Mon, 24 Oct 2005 17:19:37 +0200

> On Mon, 24 Oct 2005 21:15:45 +0800, Srinivasan S said:
> > I then tried the compilation of gpgme 1.0.3 and this aborted at the
> > first file itself with errors.  The only additional step I did was
> You need to use the current Subversion trunk.
>    svn co svn:// gpgme
> Shalom-Salam,
>     Werner

Check out the latest SMS services @
This allows you to send and receive SMS through your mailbox.

Powered by Outblaze

More information about the Gnupg-devel mailing list