Issue with certain key

Christian Biere christianbiere at
Sat Feb 25 14:53:38 CET 2006

David Shaw wrote:
> On Thu, Feb 23, 2006 at 06:55:02PM +0100, Christian Biere wrote:
> > gpg: requesting key FC05DA69 from hkp server
> > gpg: mpi larger than indicated length (2 bytes)
> > gpg: read_block: read error: invalid packet
> > gpg: Total number processed: 0
> > gpg: no valid OpenPGP data found.

> > All checks pass when I run "make check". I've also tried
> > Is there something wrong with this key?
> > According to its owner, it's alright. So it must be a bug,
> > right?

> Yes.  There are corrupt signatures on that key.  GnuPG 1.4.3 has code
> to skip the corrupt signatures rather than reject the whole key.

Thanks for confirming this. It's a little bit odd though. I'm sure I
used to retrieve this key initially and that one
uses SKS unlike which uses the broken PKS. It's really
strange but on Debian with GnuPG 1.4.2 I can retrieve the key and
cannot reproduce the warning. On NetBSD, no dice. The key seems to
have corrupted my key ring slightly too because I get that warning
whenever I use GnuPG now. It's still working fine but always emits
that warning additionally.  I even tried an empty ~/.gnupg and the
suggested but I always get the warning as above. I'll
fetch GnuPG from CVS and retry.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 188 bytes
Desc: not available
Url : /pipermail/attachments/20060225/1dbf3b9f/attachment.pgp

More information about the Gnupg-devel mailing list