gpgsm(gnupg2.0.1) keydb.c classify_user_id() problem

Mitsuho Iizuka m-iizuka at
Wed Feb 7 02:09:42 CET 2007


Could anybody give some hint to specify a user ID by email adress ?
I can't sign because of 'No public key' error as follows on Fedora
Core 5 Linux. It seems there are 3 problems such as, 1) bad user
argment, 2) bad certification, 3) not good keydb.c classify_user_id()
implementation might exist.

   gpgsm: can't sign using `<m-iizuka at>': No public key
   [GNUPG:] INV_RECP 1 <m-iizuka at>

exact command line is as follows.

   % ./gpgsm --detach-sign --include-certs 3 --status-fd 2 --local-user '<m-iizuka at>' --output smime.p7s mew5430s-F

According to the manual of gpgsm(2.0.1), it seems this user id
argment is valid. However It seems gpgsm fails to search the USER
with no need trailing '>' at the end of user-id on classify_user_id()
of keydb.c(gpgsm 2.0.1) implementation on my certification bellow.

I tried 2 other user specifying way, such as, m-iizuka at ... and
'<m-iizuka at'. Those results gave same error.
Only succeed to get a valid sign.

My certification is as follows(~/.gnupg/keyring.kbx). I would like to
emphasise I have '.' in stead of '@' in the user-id field. There is
a ordinary email address with EMail field bellow.

   % gpgsm -kv
   Serial number: XXXXXXX
   Issuer: /CN=NEC Group Certification Authority SMIME/OU=Class 2 CA - OnSite Individual Subscriber/OU=Terms of use at https:\x2f\\x2fRPA (c)99/OU=VeriSign Trust Network/O=NEC Corporation
   Subject: /CN=Mitsuho Iizuka (061221\x2frepository\x2fCPS Incorp. by Ref.,LIAB.LTD(c)96/OU=NEC Group Certification Authority SMIME/O=NEC Corporation/EMail=m-iizuka at
So in this case, WHAT is the exact problem ?

Thanks in advance

// Mitsuho Iizuka

More information about the Gnupg-devel mailing list