assuan external loop over socket

Ben Kibbey bjk at
Fri Oct 26 17:39:47 CEST 2007

On Fri, Oct 26, 2007 at 03:33:09PM +0200, Marcus Brinkmann wrote:
> At Thu, 25 Oct 2007 09:59:20 -0400,
> Ben Kibbey <bjk at> wrote:
> > 
> > The assuan info docs say connecting to a socket with the external IO
> > loop isn't supported. Are there any plans to do this in the near future?
> If you need to do asynchronous assuan communication in the client,
> then yes, there is a small function missing, which I can add easily.
> However, from your description below you seem to have trouble in the
> server, which should be fully supported already.  Can you clarify?

Right now I only need server support, but I'll probably end up needing
client support too.


> > When I connect to the socket with socat, I get an IPC read error from
> > assuan_process_next(). Maybe I'm doing something wrong?
> I never tried with socat.  You might want to try with
> gpg-connect-agent from the gnupg tools directory.  The reference
> implementations are in dirmngr and gpa.  Can one look at your code
> somewhere?

When using assuan_process() it'd show the hello line right after
connecting with socat and IO with the server worked as usual. Checkout;a=blob;h=87ee996a02c16d7e716228727f7720df87adfb65;hb=86bea292a49f09c7083d76984f34c520b4204ce6;f=src/pwmd.c#l334. I've tried both pth_event() and select() on the FD and assuan_process_next() still gives me the IPC read error.


Benjamin J. Kibbey bjk at
3019 F5FC AA33 5BC7 BE9F 09D2 393E DBD2 40D5 FA7E

More information about the Gnupg-devel mailing list