cross compilation and GPGME: Invalid crypto engine error

Oguz Yarimtepe comp.ogz at
Tue Mar 10 16:24:10 CET 2009


I cross compiled gpgme1.0-1.1.5 for STLinux2.2 system. First i cross
compiled and installed pth-2.0.7, then libgpg-error-1.4, gnupg-1.4.6 and
gpgme1.0-1.1.5. I disabled lfs while compiling gpgme. After installation
i compiled my c code. When i ran the binary, i got the error message
saying "GPGME: Invalid crypto engine error" at the line 111 that is
gpgme_engine_check_version function. 

At the cross compiled system, i ran gpg --list-keys and i could see the
keys. Also i could see the gpg -se -r "something" test.txt working. gpg
-d also working. 

I might be doing something missing. Maybe some library files are
missing. When i ran "gpg --list-keys" first time i had libbz2 and libusb
errors saying the so files are missing. I found them from the devkit and
transferred them to the cross platform. 

I will be happy if you give some clues to understand what the problem
is. I may try recompiling or check some log files but i am not sure what
to look. 


More information about the Gnupg-devel mailing list