libgcrypt 1.4.6 mpi on amd build fails?

Bernhard Reiter bernhard at
Wed Jan 19 09:34:23 CET 2011

Am Mittwoch, 19. Januar 2011 09:12:34 schrieb Werner Koch:
> On Tue, 18 Jan 2011 15:29, bernhard at said:
> > This is on Debian Lenny 32 userland, running the 2.6.26-2-amd64 (Debian
> You are cross-compiling from ia32 to amd64. 

I don't mean to, I am just running a 64 kernel, but full user land, so I want 
to build for ia32 which any other build I've tried did. 

> You need to use a correct 
> cross-build setup which you obviously don't have.

If libgcrypt's mpi configure has detected a cross-build setup, 
looks like a defect to me.

Grant, thanks for the hint below:

Am Mittwoch, 19. Januar 2011 04:42:38 schrieb Grant Olson:
> I had a similar problem compiling on mac.  running ./configure with the
> --disable-asm flag fixed it for me.  I'm not sure if that'll help you
> out, but it's worth a try.

Yes, this is what I did afterwards and it worked. Switching off the assembler

Managing Director - Owner:       (Free Software Company)
Deputy Coordinator Germany: Board member:
Intevation GmbH, Osnabrück, DE; Amtsgericht Osnabrück, HRB 18998
Geschäftsführer Frank Koormann, Bernhard Reiter, Dr. Jan-Oliver Wagner
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3696 bytes
Desc: not available
URL: </pipermail/attachments/20110119/b3c56c27/attachment.bin>

More information about the Gnupg-devel mailing list