gpg-agent: use --disable-scdaemon, yet still get SC-related error?

Jim Meyering jim at
Mon Nov 28 15:08:08 CET 2011

Stef Walter wrote:

> On 2011-11-27 22:38, Jim Meyering wrote:
>> Does this ring a bell with anyone?
>> I'm using gpg-agent from Fedora 16's gnupg2-2.0.18-2.fc16.x86_64,
>> invoked with these options:
>>      exec gpg-agent --daemon \
>>          --disable-scdaemon \
>>          --enable-ssh-support \
>>          --use-standard-socket \
>>          --log-file $HOME/.ssh/log \
>>        $HOME/.xinitrc-real
>> Yet in spite of that --disable-scdaemon option, I still get what looks
>> like an SC-related error in the log each time I try to use gpg:
>> (and the agent fails to do its job):
>>      2011-11-27 22:29:21 gpg-agent[13380] error getting default authentication
>>        keyID of card: Not supported
> You probably need to disable gnome-keyring-daemon's gpg-agent. It
> doesn't support certain agent commands (yet?).
> Use 'gnome-session-properties' and uncheck the 'GPG Password Agent'
> that says 'GNOME Keyring'.

Thank you for the suggestion.  That would probably help if I were using
gnome, but gnome is not involved.  The above is what I use to start X
with awesome as my window manager.

More information about the Gnupg-devel mailing list