GnuPG 2.0.18 won't use libcurl

John Marshall john.marshall at
Wed Sep 7 07:56:20 CEST 2011

The 2.0.18 configure script test for libcurl is broken.  The test
program's '#include <curl/curl.h>' directive is missing its leading '#'.
From config.log...

  configure:9374: checking whether libcurl is usable
  configure:9407: cc -o conftest -O -pipe -march=pentium4 -DLDAP_DEPRECATED -I/usr/local/include  -I/usr/local/include  -L/usr/local/lib conftest.c -L/usr/local/lib -lcurl  >&5
  conftest.c:46: error: expected '=', ',', ';', 'asm' or '__attribute__' before '<' token
  configure:9407: $? = 1
  configure: failed program was:
  ---< snip >--
  | /* end confdefs.h.  */
  | include <curl/curl.h>
  | int
  | main ()
  ---< snip >--
  configure:9421: result: no

It looks like the source of the problem is Line 144 in m4/libcurl.m4 but
patching Line 9387 in the distribution's configure file was all I needed
to do to correct the build.

This doesn't actually break the build because the 'GnuPG curl-shim'
kicks in when the build fails to use libcurl.  I guess there are lots of
2.0.18 isntallations out there running with the curl-shim!

The reason I tracked this down was that my 2.0.18 installation failed to
resolve SRV records for the supplied keyserver name prior to attempting
to query the keyserver via an HTTP proxy: there was no corresponding A
record and the query would fail.  It had worked fine previously, and
still worked fine from a 1.4.11 installation.  I enabled the debug
keyserver-option on both the 1.4.11 and 2.0.18 systems and noted that
the 2.0.18 system was showing "curl version = GnuPG curl-shim".

Thank you for maintaining this great software.


John Marshall
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 196 bytes
Desc: not available
URL: </pipermail/attachments/20110907/d7279a7e/attachment.pgp>

More information about the Gnupg-devel mailing list