porting gnupg to Android, is pth required?

Simon Josefsson simon at josefsson.org
Fri Jan 20 10:16:41 CET 2012

Hans-Christoph Steiner <hans at guardianproject.info> writes:

> On Jan 19, 2012, at 10:20 AM, Simon Josefsson wrote:
>> Hans-Christoph Steiner <hans at guardianproject.info> writes:
>>> Excellent, thanks for stepping up on this!  Here's the Android
>>> cross-compiler, its a big tarball of a custom gcc build, some libs,
>>> and some utilities:
>>> http://developer.android.com/sdk/ndk/index.html
>>> I work on Debian, Ubuntu, and Mac OS X.  I have taken to untarring the
>>> above in /usr/local, then making a /usr/local/android-ndk symlink to
>>> the versioned directory.  I also attached my bash settings to set the
>>> path and some env vars for the Makefiles.  I don't think you'll need
>>> to download the Android SDK stuff at all.
>> Thank you for pointers!  I'll start by trying to make gnulib buildable
>> in this environment...  (although not until tomorrow)
>> /Simon
> Excellent!  This is a high priority for us, so please don't hesitate
> to contact me with Android porting questions.  It can be via this
> list, direct email, or IRC.  I'm _hc on freenode and oftc.net.  I'm
> generally in #guardianproject on freenode or #debian-nyc on oftc.

I'm now up and running with the NDK, and actually got the same error as
you did when I tried to build a small gnulib based dummy project.  So it
is certainly an incompatibility between Android and gnulib somewhere.
Now, let's see if I can fix it...  I'll probably continue this thread on
bug-gnulib at gnu.org instead since it is not (yet) to do anything with
GnuPG, just gnulib.


More information about the Gnupg-devel mailing list