Fwd: Bug#753047: src:libgpg-error: FTCBFS for any architecture but mingw32 and android

NIIBE Yutaka gniibe at fsij.org
Fri Jul 4 08:21:36 CEST 2014


On 2014-07-03 at 22:48 -0400, Daniel Kahn Gillmor wrote:
> I just tried to do this for powerpc (from x86-64) and didn't manage to
> create a powerpc executable for gen-posix-lock-obj.  I'm not sure what
> i'm doing wrong, but below is a transcript of the full attempt,
> including a demonstration that the final executable is x86-64, not
> powerpc.

You need to install cross toolchain.  In the log:

> checking build system type... x86_64-unknown-linux-gnu
> checking host system type... powerpc-unknown-linux-gnu
> checking for powerpc-linux-gnu-gcc... no
> checking for powerpc-linux-gnu-ar... no

I think that your system doesn't have cross toolchain.

I don't know why configure didn't fail in this situation.  Perhaps, it
assumed that standard 'gcc' should have capability to compile for the
host powerpc-unknown-linux-gnu.

> Pointers to the proper way to set up cross-compiling (if that's what
> i'm missing) would be welcome.

I don't have enough knowledge of current cross toolchain for Debian,
but it seems that there are packages by Ubuntu:


I haven't tried those packages, though.  Just FYI.

More information about the Gnupg-devel mailing list