gpg 2.1.1 --recv-key fails ("Input/output error") for a specific key

Daniel Kahn Gillmor dkg at
Tue Feb 10 18:40:32 CET 2015

On Tue 2015-02-10 10:15:08 -0500, Daniel Kahn Gillmor wrote:
> Hi GnuPG folks--
> One key from the public keyservers appears to cause gpg 2.1.1 to fail to
> import:
> 0 dkg at alice:~$ gpg2 --keyserver --recv 0x99AB06246EEBF5A8 
> gpg: keyserver receive failed: Input/output error
> 2 dkg at alice:~$ 
> This happens with hkps, with plain hkp, with the pool, and with all the
> different distinct keyservers i've tried.  The same command is not a
> problem for gpg 1.4.x.

Sorry, i take it back.  this is a problem specifically with hkps fetches
and this key.  I hadn't realized that gpg2 --keyserver arguments were
being ignored.

I've been fetching other keys successfully with hkps://
(with the appropriate hkp-cacert set in dirmngr.conf [0]), though; only
this key is failing.

I've tried to get other hkps session set up to test other servers, but
have only had authentication failures with them :/



More information about the Gnupg-devel mailing list