Problems with HKPS pools (GPG 2.1.1)

Adam Ehlers Nyholm Thomsen adament at
Fri Feb 13 13:30:50 CET 2015

Dear GnuPG developers,

I tried setting my keyserver to and most 
times when trying to refresh keys I got:

gpg: refreshing 12 keys from hkps://
gpg: keyserver refresh failed: General error

Activating debugging for dirmngr there seemed to be a number of 
different reasons for this, depending on which server dirmngr chose to 
contact.  However most of these seemede to be related to hostname 
verification.  Would it be possible to give a more meaningful error 
message so that this would be clearer to the user?

Another seemed to be that dirmngr insisted on contacting the same server 
the whole time.  Is this intended behaviour?  Would it maybe be 
reasonable for dirmngr after a certain number of hostname verification 
errors to give up and try another server?

I ended up killing gpg-agent and dirmngr and relaunching them a number 
of times. Every once in a while it would pick a good server and then 
everything worked.

Adam Ehlers Nyholm Thomsne
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 473 bytes
Desc: not available
URL: </pipermail/attachments/20150213/602071d8/attachment-0001.sig>

More information about the Gnupg-devel mailing list