Problems with pip install gpg

Neal H. Walfield neal at
Wed Dec 21 20:54:47 CET 2016

On Wed, 21 Dec 2016 19:25:59 +0100,
Werner Koch wrote:
> On Wed, 21 Dec 2016 17:18, bre at said:
> > $ apt-cache rdepends python-gpg |grep '^ ' |wc -l
> > E: No packages found
> > 0
> That is because Python folks tend to write their own binding.  I have
> seen many of them - including Mailpile.
> I somewhat lost the context - what was your point?  That the new gpgme
> python bindings are not yet in widespread use?  You can't seriously
> claiming that given that we released them only 3 months ago.

The problem, as I understand it, is that Python developers expect
packages installed using pip to install their "strong" dependencies.
In this case, that would be gpgme.

Not being a Python developer, I can't comment on this.  But if this is
how the ecosystem works, then I think we ought to seriously take this
into consideration.  This is particularly the case if we want to
encourage people to use our new bindings (and we did actively
encourage Bjarni to transition to them and drop his own

FWIW, in Justus' original announcement, he said:

  If you cannot wait until pyme3 is packaged by your distribution, and
  you do not want to build GPGME 1.7 from source merely to get pyme3,
  you can build it out-of-tree provided you have at least GPGME 1.6, the
  Python development packages, and SWIG.

GPGME was released in August 2015.  I suspect that all current
distributions except Debian (which has 1.5) satisfy this requirement.
1.7, on the other hand, was released this past September.

More information about the Gnupg-devel mailing list