Bug: wrong new signatures count during `gpg --recv`

Anatolii Borodin anatoly.borodin at gmail.com
Wed Feb 21 09:16:11 CET 2018

Hi All,

every time I run `gpg --recv 6BD9050FD8FC941B43412DCC68B7AB8957548DCD`, it says

gpg: key 68B7AB8957548DCD: "Werner Koch (gnupg sig) <dd9jn at gnu.org>" 2
new signatures
gpg: marginals needed: 3  completes needed: 1  trust model: pgp
gpg: depth: 0  valid:   5  signed:   0  trust: 0-, 0q, 0n, 0m, 0f, 5u
gpg: next trustdb check due at 2030-01-01
gpg: Total number processed: 1
gpg:         new signatures: 2

But there were no 2 signatures in the mean time (3 seconds).

These "signatures" are also counted during `gpg --refresh`, which is
misleading and a bit annoying.

I tried to delete and reimport the key, but the bug stays.

Checked in gpg (GnuPG) 2.1.15, Ubuntu Bionic (devel), Ubuntu Artful, etc.

PS Sorry if it's a known problem. I tried to google it but couldn't
find anything related to it.

Mit freundlichen Grüßen,
Anatolii Borodin

More information about the Gnupg-devel mailing list