Problems compiling gpg with FreeBSD 2.2.6

Alan Ferrency
Tue, 27 Jul 1999 13:01:29 -0400 (EDT)

Hello there.

I had some problems compiling GnuPG 0.9.9 for FreeBSD 2.2.6.  I
resolved them and was able to compile successfully, but I'm wondering
if there was a Better Solution than twiddling the code directly, and
if this is a known problem.

The problem:

Source files mpi/*.S were compiling with incorrect symbols, missing
the leading underscore.  For example, mpih-add1.S was producing a .o
with the single symbol "mpihelp_add_n" instead of "_mpihelp_add_n".
This left a bunch of unresolved symbols in libmpi at link time.

I solved this by going into mpi/*.S and prepending underscores to all
of the symbols.  This worked, but I can't help but think there's a
better way, maybe a switch to gcc or something, to produce the correct
symbols, since obviously others aren't having the same problem on
other platforms.

GNU Make version 3.76.1
gcc version

Any other vital stats required?

Thanks for any clues anyone can lend me; I'll go see if it works now.

Telerama Public Access Internet