Installation of RSA/DSA plugins

Michael Roth
Mon, 21 Jun 1999 00:29:01 +0200 (CEST)

On Sun, 20 Jun 1999, Brian Galbraith wrote:

> When I type in the compile command (as per the instructions) I get the
> following response.
> gcc: fPIC: No such file or directory
I'm absolutly sure, you typed the command line wrongly. If you are on an linux box (what else ;-) use the following command lines _without_ the quotes: To compile IDEA: "gcc -Wall -O2 -shared -fPIC -o idea idea.c" To compile RSA: "gcc -Wall -O2 -shared -fPIC -o rsa rsa.c" Be sure you type the command lines exactly as described above. It looks like that you forgotten to type a minus sign the last time you tried. Please note, as always: case matters! You will see some warning messages when you compile the two modules. You can simple ignore them. These are only warning. These are for developers only. The compiler thinks, their could be some problems with the source, but the compiler is wrong. ;-) Just trust the developer of the source and ignore these warnings. ;-)
> I have never tried a c compilation before ..any comments as to what is
> wrong or lacking (apart from basic knowledge)
It is very important to use the correct command line. Minor changes in the command line result in a totally different result. Just as anything on Linux. ;-) cu Michael