Exporting & Importing Public Keys

Petr Danecek petr@ics.cas.cz
Tue, 29 Jun 1999 17:07:24 +0200 (CEST)


I am new here, so my question may be silly.
I have a problem with exporting and importing public keys.

User A exported his key using the command:
	gpg --export A > a-key.pub

User B imported his key using the command:
	gpg --import a-key.pub

Then B did run
	gpg --edit-key A

and set
	trust: full

It showed this message:
	pub  1024D/6C8E3EDD  created: 1999-06-29 expires: never      trust: f/q
	sub  1024g/C8AD5FCB  created: 1999-06-29 expires: never     
	(1) A

Then A exited the program and wanted to encrypt a file "trial.txt":
	gpg -e -r A trial.txt

And he got this message:

Could not find a valid trust path to the key.  Let's see whether we
can assign some missing owner trust values.

No path leading to one of our keys found.

1024g/C8AD5FCB 1999-06-29 "A"

It is NOT certain that the key belongs to its owner.
If you *really* know what you are doing, you may answer
the next question with yes

Use this key anyway? 

He tried again:
	gpg -e -r --yes A trial.txt

But he he is getting still the same.
He needs to run the command non-interactively.

Any ideas?

Thank you in advance,
	Petr Danecek