trust not calculated correct

Roland Rosenfeld
Sun, 24 Oct 1999 23:26:30 +0200

Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: quoted-printable

I have the following problem with GnuPG 1.0:

One of the keys in my pubring seems not to be integrated into the
web-of-trust, which means that the "calculated trust" is set to "q"
instead of "f".  Look at this:

$ gpg --edit-key DB089309

pub  1127R/DB089309  created: 1997-03-17 expires: never      trust: f/q
(1)  Lutz Donnerhacke <>

Command> check
uid  Lutz Donnerhacke <>
sig!       39F37F5D 1997-03-17   Lutz Donnerhacke <Lutz.Donnerhacke@Jena.
sig!       593238E1 1997-12-10   Thomas Roessler <>
sig!       DB089309 1997-03-17   [self-signature]
21 signatures not checked due to missing keys

As you can see, DB089309 is signed by two keys (39F37F5D, 593238E1),
which are both fully trusted:

$ gpg --edit-key 39F37F5D

pub  2048R/39F37F5D  created: 1996-04-25 expires: never      trust: f/f
(1)  Lutz Donnerhacke <Lutz.Donnerhacke@Jena.Thur.De>
(2)  Lutz Donnerhacke <>

$ gpg --edit-key 593238E1

pub  1280R/593238E1  created: 1996-01-19 expires: never      trust: f/f
(1)  Thomas Roessler <>
(2)  Thomas Roessler <Thomas.Roessler@Sobolev.Rhein.DE>

So If I don't miss anything, this should imply that the computed trust
of DB089309 should also be "f" instead of "q".  I didn't configure
completes-needed, marginals-needed and max-cert-depth, so two fully
trusted signatures should be more than enough to mark the key fully

gpg --update-trustdb and gpg --check-trustdb don't change anything.

gpg --list-trust-path DB089309 doesn't display any path.

I tried the following sequence of commands:

gpg --export-ownertrust > ownertrust.export
mv trustdb.gpg trustdb.gpg.old
gpg --import-ownertrust < ownertrust.export
gpg --update-trustdb
gpg --check-trustdb

but this also didn't fix this key (I noted a similar problem with
39F37F5D (see above), and it solved my problems with 39F37F5D, but
with DB089309 it doesn't work).

Any idea what's wrong here?

I use GnuPG 1.0 with rsa and idea modules on a Debian system
Linux spinnaker 2.2.13 #1 Mit Okt 20 18:48:12 CEST 1999 i586 unknown
with libc6 2.1.2.



 * * *

Content-Type: application/pgp-signature

Version: GnuPG v1.0.0 (GNU/Linux)