importing other keys

Eric Hanchrow
08 May 2000 10:57:25 -0700

>>>>> "Micah" == Micah Anderson <> writes:
Micah> Hello.... I asked someone for their pgp key and they gave me a web page Micah> which has two different keys on it. I tried both of them and gpg would not Micah> import either. Here are the headers from the keys: I just got it to work, after having failed the same way Micah did. Here's what I did: * I visited the web page with Netscape. * I dragged the mouse over the key blocks, thus copying the keys into the X select buffer (or whatever it's called) * I used GNU Emacs to visit a new file, and yanked the keys into the file's buffer by typing control-Y. * I saved that file as /tmp/keys, then at the shell, typed `gpg --import /tmp/keys'. This failed with this message gpg: no valid OpenPGP data found. gpg: Total number processed: 0 * Then I had a brainstorm: I deleted the trailing whitespace from the file by typing, in Emacs, M-x replace-regexp RET [ SPC tab ] + $ RET RET * Then I saved the file, and re-did gpg --import. This time it worked. -- PGP Fingerprint: 3E7B A3F3 96CA 8958 ACC5 C8BD 6337 0041 C01C 5276