Unable to load IDEA extension on MacOS X Server 1.2

Stephane Corthesy stephane@sente.ch
Tue, 28 Nov 2000 17:54:15 +0100


I tried to compile and use IDEA module for gpg 1.0.4, but it seems  
it is never loaded.

I downloaded idea.c from

compiled it with
cc -Wall -O2 -shared -fPIC -undefined warning -nostdlib -o idea idea.c

installed it into /usr/local/lib/gnupg/, added load-extension idea  
to ~/.gnupg/options, and gpg still doesn't load it.

> gpg -v -v --version
gpg: can't mmap pool of 16384 bytes: Invalid argument - using malloc gpg: Please note that you don't have secure memory on this system gpg (GnuPG) 1.0.4 Copyright (C) 2000 Free Software Foundation, Inc. This program comes with ABSOLUTELY NO WARRANTY. This is free software, and you are welcome to redistribute it under certain conditions. See the file COPYING for details. Home: ~/.gnupg Supported algorithms: Cipher: 3DES, CAST5, BLOWFISH, RIJNDAEL, RIJNDAEL192, RIJNDAEL256, TWOFISH Pubkey: RSA, RSA-E, RSA-S, ELG-E, DSA, ELG gpg: loaded digest 1 gpg: loaded digest 2 gpg: loaded digest 3 Hash: MD5, SHA1, RIPEMD160 What am I doing wrong? Stephane -- Archive is at http://lists.gnupg.org - Unsubscribe by sending mail with a subject of "unsubscribe" to gnupg-users-request@gnupg.org