Can't decrypt .gpg file

Jack McKinney
Tue, 28 Nov 2000 13:56:08 -0600

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Big Brother tells me that Florian Weimer wrote:

> "Jack McKinney" <> writes:
> > > Could you send us the first five hundred bytes of the file in
> > > question?
> >=20
> > Got it. I created an archive using the attached gpgtar script (whi=
> > has worked successfully often) with passphrase "test".
> Okay, there are 4 superfluous new line characters on it (hmm, I get
> only two here). Otherwise, it appears to be fine. Most likely, these
> are the result of the "echo" lines in your gpgtar script. I'd suggest
> to redirect output to stderr for them as well, and they should vanish.
> It's possible that the "read" calls write to stdout as well, resulting
> in more newline characters.
Duh! I gave up on debugging the fact that my two pass phrase requests apepared on the same line a long time ago. Serious brain lapse in not realizing that they are going to stdout (esp. considering that I had the foresight to print the prompts to stdout!) Thanks VERY much for the help. I guess I'll need to write a filter to skip the first two bytes before passing these files to gpg! BTW... any idea why this sometimes works and sometimes doesn't?
> I'm not sure if shell (even zsh) is the right programming language for
> this kind of task. :-/
How so? Initially I ran this from the command line, and put it into a shell script mainly so that I would not have to rethink the syntax and retype it each time. The only issue I can see is the storing of the pass phrase in a shell variable. Since this is a single user machine that is not connected to the network, and I can wipe the swap partition fairly easily (not that it is used much), that issue is pretty non-existant. Again, many thanks for solving this for me. -- "I'll never be cruel to electrons Jack McKinney in a particle accelerator again." -the Fourth Dr. Who, "The Pirate Planet" 1024D/D68F2C07 4096g/38AEF076 --k+w/mQv8wyuph6w0 Content-Type: application/pgp-signature Content-Disposition: inline -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.0.4 (GNU/Linux) Comment: For info see iEYEARECAAYFAjokDdgACgkQimeon9aPLAdnnACdEi3tLSy9VYOvmUkXcLJ6h7bz KpAAn0bf0Z498ZnGCm7XsQGoKvvP9JA6 =9RpG -----END PGP SIGNATURE----- --k+w/mQv8wyuph6w0-- -- Archive is at - Unsubscribe by sending mail with a subject of "unsubscribe" to