can't import public key

Foltynski, Jarek D
Fri, 6 Oct 2000 13:31:20 -0500

Thanks a lot!!! I imported it successfully.

But now I have another problem. I can encrypt a file 
manually, but gpg asks me always to confirm the 
operation (even if I signed imported public key with 
local private key and set trust mode to full: 
--edit -> trust -> 4).

I would like to create automated process.
I tried use option --yes, but did not work.

Is there any way to do that?



-----Original Message-----
From: No User []
Sent: Friday, October 06, 2000 11:44 AM
To: Foltynski, Jarek D
Subject: Re: can't import public key

[Friday, 06/10/2000] Foltynski, Jarek D:

> I tried to import pgp key (attached) created by Network Associates PGP
> version 4 (I guess).
> The following error occurred:
> gpg: key A13350AD: no valid user IDs
> gpg: this may be caused by a missing self-signature
> gpg: Total number processed: 1
> gpg: w/o user IDs: 1
Jarek, this is an RSA key created with some old version of pgp, which lacks a self-signature. Adding the '--allow-non-selfsigned-uid' option to your command will tell gnupg to accept the key. $ gpg --allow-non-selfsigned-uid --import ANRPL.asc (You must be using version 1.0.3 in order to be able to use RSA keys) -- Archive is at - Unsubscribe by sending mail with a subject of "unsubscribe" to